quinta-feira, 28 de novembro de 2013

Calc - Gambiarras

Em nossas necessidades de usuários de computador precisamos de funções que muitas vezes não temos ou desconhecemos existirem num programa. Noutras, apesar de não ter o recurso do jeito que (elegantemente) queremos podemos fazer a tal da “gambiarra”. Vou mostar o caso de se querer contar uma palavra ou sequencia delas em uma célula do Calc.

A maneira elegante de contar palavras no Calc é usar a função =CONT.SE(), mas ela só funciona com o conteúdo total que estiver na célula. Se estiverem vários nomes separados em linha a função retornará zero. Então, aqui vem a gambiarra, na coluna ao lado, em cada linha deveremos colocar a fórmula =SE() seguida da fórmula =PESQUISAR() as quais deverão ser combinadas mais ou menos assim: =SE(PESQUISAR($D$1;A1);1). Os cifrões em torno da nomeação da célula D1 são para que ao arrastar a fórmula somente sejam mudados os endereços da célula A, visto que a palavra a ser pesquisada será digitas na célula D1.

Após isto, é só colocar a fórmula =CONT.SE(B1:B17;"VERDADEIRO") no lugar que se quer que saia o resultado. Vejam o arquivo em anexo que tem exatamente este exemplo que citei acima como fazer.

quinta-feira, 14 de novembro de 2013

Indescritível é o que posso dizer.

Estas imagens são de 1976 e mostram o primeiro contacto de uma tribo da Papúa Nova Guiné com um homem branco. A tribo chama-se Toulamb.

Comparando: é como se nós encontrássemos com seres de outros planetas, mais evoluídos e que desse momento para frente nos fariam aderir a sociedade deles... acreditando inclusive em seus deuses. Mas uma coisa é certa.... é extremamente interessante.

segunda-feira, 4 de novembro de 2013

Usando um editor de texto com Estilo

Na verdade o assunto é monografia, mas fazer uma monografia bem formatada é necessário ter estilo (olha o duplo sentido num sentido legal) ;). Muita gente reclama na hora de fazer uma monografia. Vamos diminuir as reclamações (espero) ajudando os alunos e professores também em pelo menos três coisas:
 - a usar programa gratuito e de qualidade para fazer a monografia, na verdade é muito mais que isto.
 - mostrar como faz a formatação através da utilização de estilos, ou seja, retrabalho nunca mais.
 - ganhar um arquivo "com estilo" (desculpe, mas não resisti o trocadilho). Se alguém gostar, por favor clique naquela mãozinha abaixo do vídeo com sinal de positivo... quem sabe eu faça outro. Se ficou com medo disso e só não clicar (risos).

Depois de terminar seu trabalho você já terá sido introduzido ao programa que vai dar o troco para os USA por nos ter espionado.Pela suíte de escritório, nunca mais em?

Você sabia que os concursos públicos já estão cobrando conhecimento sobre estes programas? Prepare-se.

Arquivo para download: Baixar arquivo com estilo